TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Mac Pro v3 - Install Message - "This installer requires admin privileges to run"
Read 31902 times
* September 12, 2008, 06:36:12 AM
Hi  :) I am looking for help to jump the first hurdle.

Running Mac OS X 10.5.4 with everything up to date and checked out the TurboCad CD using Mac's Disk Utility to find that it is apparently OK.
Needless to say I am logged in as Administrator and think I have tried all the usual methods of encouraging the DMG file to install.
Clicking on the DMG file produces the message "This installer requires admin privileges to run" and the only option button available is 'Quit'.
The getting started printed copy supplied in the package does not specify how TurboCad should be installed, but rather moves straight on to explain how to launch the product.
This subject is not covered in the WIKI pages [referenced in the Getting Started pages of these forums] and IMSI support for the product takes the visitor on a spiral journey to without resolution, i.e. selecting TurboCad for Mac and entering a query reveals plenty of answers but these are all for PC based versions.

As a switcher to Mac of less than a year I am hopeful of being able to revisit some of my old PC TurboCad files [when they are converted?] 8).

Any help will be gratefully received.

Best regards, STM

Logged


* September 12, 2008, 06:49:05 AM
#1
It might be an idea to check that your privileges are set to your user name and not 'system'. I had these problems after I installed it, I had to change privileges for every folder.

I'm not sure what you meant about 'converting' your old PC TurboCAD files. TC for Mac is an entirely different beastie to TurboCAD Windows, there is no common ground at all.

Regards...... Alan.

Logged


* September 12, 2008, 09:15:33 AM
#2
Thanks for your reply Alan.

The setting is definitely under my name, I am the sole user, there has never been any issues with permissions for the multitude of software I have installed on my Mac.

Sorry that I was unclear regarding the 'conversion' of TurboCad files from PC to Mac, when I was about to switch information was obtained from Avanquest [IMSI Distributors in the UK] regarding what action was needed to be able to access the old files:

Quote
In reply to your email, you won't be able to open old TCW
files but what you can do is to either download a trial version of
TurboCAD 14 for the PC and as long as you have Windows installed under
boot camp or virtualization software like Parallels Desktop or VMware
Fusion you can install the PC version of TurboCAD and then access the
TCW files.

The second option is to save the TCW files as DWG or DXF files and then
you can open the files in TurboCAD Mac 3.0.

I am already running my copy of TurboCad in Windoze on a VMware Fusion Virtual Machine running under OS X so it is just a case [once I get up and running with the TurboCad for Mac :D] of finding out the best format to use for the transfer.

Thanks for your time, STM

Logged


* September 12, 2008, 12:10:55 PM
#3
Updating the above.

With the intention of verifying any permissions problems on my own Home Account I have created a New Administrator Account and logged in under it's name and password.

Unfortunately the exact same scenario plays out and I am still unable to install TCM3.

[edit]
I have tried Resetting PRAM and NVRAM to no avail.

I run a Mac Pro with 2 Optical Drives and tend to use the upper one most of the time, as a matter of curiosity I tried the offending disc in the lower drive.
Using the lower Optical Drive the TCM3 disc was not recognised and after a while it was auto ejected and nothing appeared on the screen at any time.
The OS X Installation Discs and Office for Mac 2008 Installation Disc can be read by both drives, self Burned DVD and CD discs are also similarly read by both drives.
In fact I cannot find any other disc that cannot be read by both drives.
This leads me to suspect that the TCM3 Installation disc is faulty, close inspection does not reveal any fingermarks or scratches that might cause this problem. The disc was taken fresh from a sealed package prior to this attempted installation.

Perhaps there are other actions that could be tried before returning the package to the Vendor?
[end of edit]

Thanks for reading this, STM
« Last Edit: September 12, 2008, 12:59:25 PM by StanTheMan »

Logged


* September 17, 2008, 04:31:47 AM
#4
Further Update on the above:

I obtained a copy of DiskWarrior and ran the checks on my Mac and it's HDDs.

Apart from a moderate amount of optimisation that DW said was required there was nothing amiss with my system. The 'repairs' were permitted prior to re-attempting the installation with the originally supplied TCM Disc.

Shortly after completing the above I received a replacement TCM Installation Disc, kindly sent by the Vendor, but this behaves in exactly the same manner as described when attempting to install from the original TCM Disc.

Perhaps I am doing something wrong, TCM seems to require a different MO to most other Mac Software but I think all possible routes have been explored.
The TCM Disc is inserted [using the upper drive as the lower will still not read the disc] and the TCADMacPro3 'Gear Wheel' Icon displays. Opening this runs the verification, displays the mounted TurboCAD Mac Pro 3 'Disc Drive' Icon and also displays attachment B:. Running the DMG file [or dragging it onto the Desktop and running it from there makes no difference to the result].
The attachments and explanations below show what I have done in attempting to get TCM Pro v3 to install. Dragging the DMG onto the Mac and running it from there makes no difference, nor does 'Opening' rather than simply clicking.

The attachments show:
A: Full Screen Shot of the failed attempts
B: First Window displayed showing DMG File [at the top right] which is clicked to activate C:
C: Second Window displayed showing the 'Double Click to Install' Icon which when double clicked [or 'Opened', produces D:
D: Warning Notice displaying the message 'This installer requires admin privileges to run'

I hope these attachments will not be too small to be of use.

All of which raises more questions:

Is it possible that this is a 'Volume License' or any other restricted version of TCM Pro v3?

What is the next level up from this version, there does not appear to be a TCM Pro v4?

Thanks in advance for any help or advice you care to impart, best regards, STM


Logged


* September 24, 2008, 12:10:17 PM
#5
I am having the exact same issue.

G5 iMac single processor 2Ghz

2 GB RAM

Over 100 GB of free disk space.

MacOS 10.5.5

I am installing from an Admin account. This is the first time I have ever seen this type of error massage. Usually during an install that requires some admin privileges a window pops up and requires you to enter in a password for the admin level account you are logged into. This is not happening.

Thanks,
Len

Logged


* September 24, 2008, 06:53:08 PM
#6
Update:

1) I copied the file "TurboCAD Mac Pro v3.0(Double Click to Install).app" from the CD to my desktop and tried running it from there.  I got the same error message.

2) From the terminal I ran the installer "/Users/ltomko/Desktop/TurboCAD Mac Pro v3.0(Double Click to Install).app/Contents/MacOS/installer" with the same error. The unix permissions for this file were "-rwx------  1 ltomko  staff  502108 Oct 28  2007 installer" which indicates that I was the owner and had read/write/execute permission.

3) My last attempt was to change to superuser (sudo su) and run the command.  I got the same error message.

Stumped  ???

Logged


* September 25, 2008, 01:52:40 AM
#7
Hi Len :)

................[stumped] and out of the game?  ;D

I am sorry to hear you are suffering a similar fate, you have followed a similar route to mine and have arived at the same destination. Having tried a second TCM Pro v3 Installation Disc and being advised by IMSI Support to do exactly what I have already done several times, perhaps it is time for me to give up on TCM?

As with your case the 'usual' Password Request was never presented during any of the very many attempts made to install TCM Pro v3. Also I ensured that for most of my installation attempts no software, other than Mac Essential items, were running at the same time. My Mac Pro [early 2008 8 core 2.8GHz with 4GB RAM] also has hundreds of GB of vacant space so equipment specification should not be in question.

There is an almighty mess regarding the various sites e.g. TurboCad.co.uk offer TCM Pro 2008 at
« Last Edit: September 25, 2008, 01:59:17 AM by StanTheMan »

Logged


* September 26, 2008, 02:02:01 AM
#8
Hi Guys,

I really had no trouble with my installation of v.3 but one thing has just dawned on me. You all seem to be installing from disc, mine was from a download

Logged


* September 26, 2008, 10:21:02 AM
#9
Hi Alan

Thanks for the input, I am pleased to learn that it is possible to run TCM Pro v3

I have searched and searched for such a TCM Pro v3 Download, and whilst communicating with IMSI Support they did not mention the possibility of that route.

Without 'broadcasting' the contacts full eMail address details can you give a few more clues as to where he may be contacted?

If you choose to reply perhaps you will be kind enough to give some idea of the date and origin of your TCM Pro v3 Download, and whether it was purchased as a Download or supplied as a result of a Disc Installation issue?

Best regards,
STM

Logged


* October 10, 2008, 05:00:46 AM
#10
Hi Stan,

I've been on vacation, just read your last posting. Rip's email address is found in a posting I made in Problems. 'Problems activating TurboCAD Mac De Luxe 2D 3D V.4.

I hope you get some joy, at last.

Regards...... Alan.

Logged


* October 10, 2008, 06:42:20 AM
#11
Thanks for your reply Alan  :).

I stumbled across the info in the post you mention but by that time I had made the decision to Save As/Export my TCW files to DXF/AI and then open them in Adobe Illustrator. This satisfies my immediate need to view/review old files and my 3D requirements can be filled by Google Sketchup. If a new TCM Pro version becomes available in the future I will consider the investment, hopefully a download trial will be offered so that any installation issues can be detected prior to purchase.

It seems that your suggestion regarding Download v Disc Installation is 100% correct. Accepting the minuscule user base sampled it is definitely 2 Disc Installations Failed and 1 Download Installation Success. It would be really great to learn of more success stories, from either camp.

In the interests of recording this saga fully the following is added:

Whilst reviewing my Mac Console Log for another program my eye was drawn to the TurboCad entry. Each entry consisted of just two short lines:
-------------------------------------------

Installation started on 2008-09-12 11:51:09 +0100
TurboCAD Mac Pro v3.0(Double Click to Install)

-------------------------------------------

This was repeated for each of approximately 30 installation attempts over a period from the 9th September 2008 to 17th September 2008.

Best wishes,
STM

Logged


* October 08, 2009, 08:05:38 AM
#12
Don't know if anyone managed to solve the issue, but I had a similar problem when re-installing TurboCAD Mac Pro v2 in my new MacBookPro recently.

The solution is quite simple, but not obvious.

regards

Richard

------

Go to the installerscript.plist for the program (which is contained in the package contents of the installer icon) and editing one line in it. If you look through the installer script for a line that says

<key>Require Admin</key>
<string>TRUE</string>

replace the word true with false then save and try the install again. In order for this to work you must drag the installer onto your hard drive from the opened .dmg the installer comes in. This may help bypass your issue.




Logged


* November 18, 2009, 01:08:14 PM
#13
Hi guys
i have the same problem with turbocad mac pro v3 trying to install on mac book pro running snow leopard
i am new to macs and completely computer illiterate i can just about find the desktop so looking for files is almost impossible
could one of you kind people do a button for button explanation how and with what to open the packet.
many thanks in advance
Simon

Logged


* April 13, 2010, 10:02:37 PM
#14
I spent a bit of time on this myself and since I found the solution I thought I needed to share it.  The last post here solved it for me.  I needed to copy it to my drive for the duration of the install but other than that it worked flawlessly.

http://discussions.apple.com/thread.jspa?threadID=2014450

Logged