TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Multitude of problems, Deluxe V6
Read 7897 times
* October 17, 2012, 10:02:43 AM
Hi, first post here   

I'm running the latest build of V6 on a 2.7 GHz I5, 4GB 1333MhHz DDR3 RAM, OS 10.8.2

I have earlier used TC deluxe 12 for PC for  a few years without any major problems, doing exclusively 2D drawings but I'm moving to MAC now and thus needed to upgrade to V6 for MAC.

Anyway, I have converted all my old files to .dwg. When importing them some get imported but a few objects get a very strange look. What was prior a few smooth splines are now grouped together as one object and some other straight lines have been added to that group (se attachment. It is not possible to ungroup to delete that extra junk, the group gets deleted!!! Furthermore some of the older files (all in .dwg format) won't import at all. I attach somewhat hesitant a file that won't import. When trying the "convert" command on some files it looks like its working, but when I open the converted files the grouped-splines-with-added-extra-junk is deleted from the rendering completely!

Additionally I cannot change color of some lines (I prefer black but when imported some (!) lines are black and some are white!!!). When right-clicking and checking TC says the color is black!

When I'm trying to delete a major part of a drawing it takes some 10-15 minutes.

I get repeated crashes were the complete program totally freeze.

Opening/importing a .dwg can take up to 1.5h (if it at all opens)

I have tried to mail the customer support e-mail address at the TC homepage but that ended up at a sales guy and he couldn't even forward my mail to the tech support. However I got the mail address to the "tech support guy" (one single guy ???) but he hasn't responded for two days now...

Sounding annoyed? You bet! This is sub standard support for something I consider a nice product. However I'm starting to consider an alternative platform and thinking about giving this Turbo cad platform the boot. I hope that someone, either from the community, or preferable from TC finally comes back to me so that I can stay with TC.

BR
Peter from Sweden

Logged


October 17, 2012, 08:25:39 PM
#1
Hi Peter welcome to the forum.
I'm sorry to say, that there have been lots of bugs with the new macs and turbo Cad. Are your file crashes being auto sent to apple? if so, that will help. I do know that since version 5, the general importing is totally different- for aero D type works) and in a word, exploded to micro lines compared to parent origins. I'm not exactly sure that story, I bite the bullet and start connecting the lines as needed. Check the apple support forums also, not many players of Macs outside the parent company (forums) are pleased. I'll give your files a run ( 10.7.2 Lion) and see whatenell happens.
Johnny

Logged


October 17, 2012, 09:55:26 PM
#2
OK Pete, we have problems! When I opened the dwg in Text edit, there is a parent statement of windows @ top few lines. Is there an Export (windows) which has"end of line' as the mac version?
I tried all types-DWG to DXF/TCP/changed V 4/5and all I get is 25k- the root base TCP empty file, as aan empty text file would be 8k's, however, the D load was 2.3 M's, the status bar ran Ok, upon an import,edit would show the data was connected, but the Explorer and"select all" are empty., Also, this evening there is a new update going on, Java, I tunesand HP Printer.I think this cloud crap has something to do with it as is the screwy new phone as I hear!

Logged


* October 17, 2012, 11:39:38 PM
#3
Peter,

I was unable to import your file into TC. Check the user manual pages 465 through 471 to see if any DXF/DWG import or export restrictions apply to some of your older drawings. I have three programs that import DWG format drawings of those two would not import it but the third did. Those are some nice looking guitars, lots of detail there too.

It looks to me like IMSI tech support needs to look at this drawing to advise you on how to process it.

Enjoy
Mitch

Logged


* October 18, 2012, 07:49:04 AM
#4
Thanks Johnny and Mitch.

Johnny. I couldn't really follow your second reply, the question about export (windows) with en end of line. I never made an export from the old TC deluxe 12 for PC. The files were created as .dwg from the beginning. I don't know if that is the answer. If not, please help me help you help me...

Thanks for the nice comments Mitch. Maybe there is a problem with the old PC version after all...

I have placed an support request with TC. However they are short of people (the MAC guy has become a father, I'm happy for him) and can't say when they can have a look at this... Frustrating, but I still have my old crappy PC holding together so I have a backup at least.  I have a complete library of parts and stuff to help me quickly visualize for a customer what a custom made guitar would look like. There are several hundreds of hours, if not thousands, put in working with the old TC for PC. I would hate to have to re-draw all of that again.

Anyway it seems like I have to try to build up some patience and see if TC support comes back to me

I will also try to get back to the PC and re-save the drawings as .dxf to see whats happening. I'll report back

Thanks again guys
Peter

EDIT: I tried to convert (actually re-save) the file as .dxf in the PC and then import that file. No success. TC doesn't seem to even try. No in progress bars, no reaction at all when I initiate the import.

EDIT 2: I was able to import some of the drwaings so the problems isn't likely to do with export restrictions, are they?
« Last Edit: October 18, 2012, 01:07:05 PM by Peter Naglitsch »

Logged


* October 18, 2012, 01:49:36 PM
#5
Peter,

Your dwg file is an AutoCAD 2004, 2005, 2006 format (AC1018). Try saving/exporting it as an R2000 format (AC1015) to see if TC can read that. I have never used any windows version of TC and have no idea what if any export restrictions might apply to that version. I can see you have a lot of time invested into that drawing and would like to save it - good luck.

Enjoy
Mitch

Logged


October 18, 2012, 10:57:40 PM
#6
same thing -- I did convert to text, as IMSI Is the Windows Parent,and Ashlar Vellum is the Mac parent
here's what i mean on the end of line
I'm sending the Text to dave, as the file size is 5 m's
Johnny

Logged


* October 19, 2012, 06:04:26 AM
#7
I only have AutoCAD 2000 and Autocad R14 as options to Autocad 2004/2005 when saving/converting in the PC.

I also tried to mess around a bit with the different conversion alternatives, but no change...

I'm not sure the problems comes from me being unable to save the original files in a more "modern" .dwg or .dxf format as I can open some of them and not other. Anyway, as said before, I'g grateful for you efforts.

Logged


October 20, 2012, 12:41:35 AM
#8
Hi Pete! This time I was quick enough to get where we need to be. Under my cursor on software- there are listings, I do remember Version 15 being there, but forgot during screenshootings what else is there- that would be the last chance, other than Dave being able to help.
Johnny

Logged


* October 20, 2012, 01:25:03 PM
#9
Johnny, I tried a few of the conversion combinations, but without success. I'll have to wait and see what the TC support comes up with

Logged


* October 21, 2012, 02:15:48 AM
#10
The biggest problem solved!!!! And I feel a bit stupid. What was the problem? Well, I re-saved the .dwg file without the umlaut in the name (substituted for A) and it was possible to import the file in the MAC! :D

However the other problems are still there:
- The program crashes every once in a while (quite often). Extremely bad.
- The file is extremely hard to work with, like a simple zoom in takes some time and is not very smooth and generally the file takes forever to import and stuff like that. I will try to add more RAM to the MAC. I happen to have a 4G RAM here with the right specs so I will use that to double the RAM and see what happens.
- The curves (beziers) made in the PC version sometimes import as a group with a lot of other stuff, like shown in the OP. If the groups are ungrouped they disappears. Major problem as I don't really feel like having to redraw a lot of stuff.
- It is also not possible to change the colors. The program says it is black but the lines are shown in white. Minor problem, but still a bit annoying

Anyway I have found a way forward as the biggest problem now is solved. Thanks for your efforts guys.

EDIT: I doubled the RAM from 4 to 8 GB. Still the same behavior.
« Last Edit: October 21, 2012, 08:11:00 AM by Peter Naglitsch »

Logged


October 21, 2012, 04:53:06 PM
#11
OK Pete, can you post a copy and we can help?

Logged


* October 22, 2012, 04:40:49 AM
#12
OK, I attach both the original.dwg file made in TC 12 for PC and the result of an import-and-save-as in .tc3 format. In TC 12 the guitar looks like in the PDF "baryton". When opening/importing the file in TC 6 for MAC some of the beliers are grouped toghether with some lines that aren't there in the original. Like in the picture "after import". Those extra lines are grouped with the original bezier, se file "group" (next post as I haver reach max for one post...). If I try to ungroup this to delete the extra "junk" the group gets deleted. The same thing happens when I save the drawing, the grouped beliers and lines get deleted. Se file "after saving"

Logged


* October 22, 2012, 04:41:31 AM
#13
More attachments

Logged


October 23, 2012, 12:24:00 AM
#14
OK Pete, we need to give something very weird a chance:
go into Preferences: time Machine: drag/drop TCVersion 6 into the disable from time machine,
turn OFF any auto save functions.
This is one helluvalottawork (Dwg) and very gorgeous.What I had done, was try an ungroup, and saw the group disappear. I opened the explorer,andA) changed group to construction layer- no response- that being, no cursor response.
I then copied a group, then had response.I did not ungroup, but as I'm writing this, i had closed the file(saved) and some data is definately missing.
notice the object counts within the layers, as the original is gone, plus others.
Copy all: place to new program file and find out what happens.
 we were using my Snow Leopard @ work to convert many files from solidworks to autocad with great success, but I'm afraid the Mountain lion has struck- uggghh
Ipc 2 was after file close/reopen,and groups are now responding:
change to:
import dwg, save/ close reopen/ work withit, more tomorrow.
Johnny

Logged