TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Displaying Dimensional Unit Marks
Read 6219 times
* April 23, 2013, 04:50:30 AM
I recently purchased and installed Turbo Mac Pro Version 7.0.0 Build (1025).  Is there a bug with displaying dimensional unit marks on a drawing?  On the "Units" pane of the "Preferences" dialog there is a checkbox titled "Display Value Units" and when the box is checked the unit marks are not displayed on the drawing.  I have searched the Users Guide and this option is not discussed anywhere that I could find.  Please advise.

Logged


April 23, 2013, 03:45:25 PM
#1
Welcome to the forum jmkiska. Display units is how many digits you need the (tolerance/info for complex locations. the dimensioning is within it's own settings set up (inspector) will give you a 'shortcut' there.

Logged


* April 24, 2013, 01:04:45 PM
#2
jmkiska,

The display value units under TurboCAD Mac>Preference>Units only displays the units value in the Inspector and Data entry fields.

~Monizuka

Logged


* April 24, 2013, 04:20:41 PM
#3
I'm trying to figure how to show the units marks on a drawing. For example: 12.00" or 300mm.  How do I get the characters in RED to show on a drawing?

Logged


April 24, 2013, 06:08:34 PM
#4
OKjm: I get it now- there's a couple ways, here's a pic with the  necessary tools open. One is the new Mark up tool, adjusted as you need, and the other, within the Inspector.

Logged


* April 24, 2013, 08:35:08 PM
#5
jmkiska,

The easiest way is after selecting a dimension tool enter the ', ", mm, or cm in the text box after the # sign in the prompt window. This will become part of the default dimension. If you enter this while a dimension is selected then it will only apply only to that selected dimension. Selecting the architecture standard and feet/inches will also give dimension signs. The auto dimension tool will not give a text box so select a different tool. Once the sign is entered then the auto tool will follow the default standard.

Enjoy
Mitch
« Last Edit: April 24, 2013, 10:10:54 PM by mitchb »

Logged


* April 25, 2013, 05:47:18 AM
#6
Mitch - Thanks for the suggestion, but unfortunately that really is not the solution.  Anything you type behind the # sign in the prompt window is just trailing text. For example, if you have the Units in the Inspector set to millimeters and type in a " mark after the # sign in the prompt window, you will get a dimension in mm with a unit mark of ".

JBorlaug - I'm not sure exactly what you are showing me.  The pict has many tools open and I'm not sure what I'm looking at.  Can you explain further.

Logged


* April 25, 2013, 06:10:21 AM
#7
jmkiska,

To place the mm in a dimension in TurboCAD place the mm after the # sign in the inspector bar under data then selecting apply. Before completing this task I would recommend setting the drawing file units type to mm. This can also be added to every dimension at one time by selecting all of the dimensions and placing #mm in the text dialog box.

~monizuka

Logged


* April 25, 2013, 11:21:58 AM
#8
Mitch - Thanks for the suggestion, but unfortunately that really is not the solution.  Anything you type behind the # sign in the prompt window is just trailing text. For example, if you have the Units in the Inspector set to millimeters and type in a " mark after the # sign in the prompt window, you will get a dimension in mm with a unit mark of ".
Yes, you are correct it is trailing text and must be treated accordingly. If you are using millimeters why would you enter " after the # sign? Why not "mm"? Enter this as text for the default dimension and the "mm" will be displayed automatically for every subsequent dimension placed. The text box in the inspector only shows when a dimension is selected. Text placed in that box only applies to the selected dimension/dimensions.

Some other things you can do with the text box are entering text before the # sign will appear before the dimension. Deleting the # sign will cause the dimension to not show and you can enter something like "see note 5".

Enjoy
Mitch



Logged


* April 25, 2013, 01:24:20 PM
#9
Mitch,

I was just using that as an example of why not to do it that way.  The unit marks should be tied to the selection of the Units in the Inspector. It works for the "feet/inches" selection.  Why not for the other selections?  What would happen if I wanted to use a Dual dimension?  How would I "add" the unit mark to both dimensions?  This is obviously a bug or omission in the program.

Logged


April 25, 2013, 01:35:52 PM
#10
Hi

Living in the UK and using the metric system like the rest of Europe it would be very annoying, having to have to type in mm every time you added a dimension. So i am inclined to agree with jmkiska so i feel also it should be added.

This is the same way of doing mm dimensions as in v5

Brian
« Last Edit: April 25, 2013, 02:05:19 PM by thefro1957 »

Logged


April 25, 2013, 07:36:18 PM
#11
How about setting the preferences to mm?

Logged


April 25, 2013, 08:21:59 PM
#12
done, but you still have to type in mm for each measurement to add mm as it does not display without.

Logged


* April 26, 2013, 04:46:31 AM
#13
Again, I have to ask, what would happen if I wanted to use a dual dimension?  Many of my customers require their drawings to be delivered with dual dimensions, e.g. 10.00" [254.0mm]. Attached is a screen shot of what I get when I try to do this by typing the unit mark into the Inspector.

Secondly, if you would have to change the dimensional units for some reason, i.e. customer's request, you would have to go back and manually edit every dimension on the drawing if you have to type it into the Inspector all the time. Isn't adding accurate dimensions to drawings one of the main reasons for doing drawings in the first place?  TCM certainly gets the numbers accurate, but without being able to easily display the proper units of measure, the program is pretty much useless to me.

Logged


* April 26, 2013, 06:00:48 AM
#14
jmkiska,

I forward your response to the development team for further assistance and was told that currently the only way to add the mm to an existing dimension line is through the inspector.

I have also added this feature to our feature request list for a future build of the application. 

~monizuka

Logged