TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Importing stp into Turbocad Pro v10
Read 190 times
* February 26, 2019, 05:21:41 AM
Hi, I hope someone can help as I am having problems importing a step file.
When I go through either the file-import route or the simple double click in Finder route the step files cannot be opened. Trubocad just crashes.
I was trying to open a new step that I had been sent. I thought this may somehow be corrupt so I also tried the dwg I was also sent and got the same result. I then tried a step file that I had already opened some weeks/months ago and this also no longer worked - again crashing. I don't think I have had to do this since going to MacOS Mojave 10.14.1. I have downloaded the latest updates from Turbocad and the software works fine in the creation and editing of existing .tcd files.
Any ideas would be very welcome.
Thanks, Robin

Logged


February 26, 2019, 08:40:22 AM
#1
Hi Robin! are you talking Version 10 or 11? I was slow in upgrading to High Sierra, but go ahead, both are running OK there. Start there, then if it persists,send us a copy of the file plz!
Johnny

Logged


* February 26, 2019, 01:29:43 PM
#2
It looks like your program has become corrupted. You will need to do a clean install. To do that you need to drag the TC V10 application to the trash, then using the Finder "Go" menu select "Library", double click on "Application Support". Find the "com.imsi.turbocadmacpro10ESD" folder and drag that to the trash. Go to your "Downloads" folder and reinstall TC V10. Re-Launch and see if all is now working - good luck.

Enjoy
Mitch

Logged


* February 28, 2019, 01:22:40 AM
#3
Hi Mitch & Johnny,

Thanks for your responses. It is TurboCAD Mac Pro v10 that I have.

I also tried the free trial version of v11 and had the same result - the software got slightly further - the progress bar appeared (and I got excited!) however about halfway along the progress bar it stopped and froze. I tried this with both the new STEP file and one that I had previously been able to open.

I have not yet done the clean install as you suggested Mitch - my issue here is that somehow I have deleted the original download and the link from that I was originally sent no longer works as v10 has been 'deleted'. I have contacted customer service to ask for a download to be made available - fingers crossed. When (hopefully) this happens I will try the clean install. However, given the issues I am having with the trial version of v11 (just the same as with my version of v10) is there a chance that my v10 has not been corrupted?

If you have any other suggestion, please do let me know. This is extremely frustrating - I just need to open the model to create 2D dimension drawings and check the overall design and currently cannot but should be able to, right?

Thanks again for your help,

Robin

Logged


February 28, 2019, 03:37:41 AM
#4
Hey Robin!
 My BIGest frustration with V11, is yes, V 10's get "locked out" from a return to Version 10. I thought the flatten surfaces would be my big purchase with V11, but with my total file loss, ( I had converted MANY files to DXF for the Version 5-7 ( 2 different engines, but V2 and 7+ are OK together, I've reverted to 12 year old files on 9 projects! One other thing I will mention of the High Sierra: ya notice how long it takes to "grind" a secure empty trash? =(an old TCP program would take a few hours. now, High Sierra, it's seconds! However, the initial engines take a longer response time- some splines etc.= and other surface/ solid renders, take 20 minutes!
Go with Mitch's mention with a 'clean install, and if you get confused, use "clean install" for the search here, as it has become minimal since Version 10. I take it, this file is purchased?
Johnny

Logged


* February 28, 2019, 08:39:07 AM
#5
Hi Mitch, Johnny,

An update for you:
I contacted customer service and they sent a link to a latest build - ViaCAD Pro v10 - and this worked - it allowed me to import the STEP files.

Robin

Logged


* February 28, 2019, 09:03:18 AM
#6
Glad to hear that it is now working. A link to the current build of V10 is here in the Patches & Updates thread.

Enjoy
Mitch

Logged


February 28, 2019, 10:22:49 AM
#7
I for 1 am glad your direct with Tim Olsen and EVO Software! GG Robin! :D- I was thinking the file was what was purchased!

Logged


* March 01, 2019, 03:34:45 AM
#8
Hi Johnny, Mitch,

Thanks again for your help and advice.

Enjoy your weekend,

Robin

Logged