TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Saving/exporting/importing files
Read 4663 times
* November 05, 2013, 01:18:52 AM
Hi All,

I use TurboCad Deluxe V5.

I bought it maybe 4 yrs ago, started to learn but got hobbled by some problems.
For some reason I couldn't join the forum then (kept getting rejected or no response!).

Because of this, and the lack of TC mac training that was available, I went back to the 2d design software I was using before.

Time has passed of course, and I'm sure most of you are using newer versions, but I hope you can help…

I am drawing basic 2d shapes for laser cutting, and have these issues…

1.
TC keeps saving with extension tc3A. I found some info on the forum which says it is a copy. This would be fine but it does it even if I try not to - I tried changing the file type myself to tc3 and it added tc3A on the end of that, so I ended up with filename.tc3.tc3A.
If I export a tc3A file to a dwg file it ends up as dwgA - which doesn't open as a dwg file.
The times I have successfully saved the file as tc3 it won't open again - says the file is damaged.

2.
When I export files as dwg files successfully, the open them again the drawings have gone crazy in respect to scale - the objects have changed size, some are huge and some incredibly huge, and some have moved.

3. I don't know if I am exporting them correctly, in regards to choosing R13, R12 etc.

Due to all this, the laser cutting co. can't understand my drawings.
Any advise on these issues would be greatly appreciated, I'm going crazy!

Thanks.




Logged


* November 05, 2013, 07:40:00 AM
#1
arc-eye,

Which build version of TurboCAD Mac v5 is installed?

What are the specification of the computer TurboCAD Mac is installed on?

~monizuka

Logged


* November 07, 2013, 12:43:47 AM
#2
Hi Monizuka,

I have a powerbook pro using OSX v 10.7.5 with a 2.66 GHz Intel Core i7 Processor and 4GB of memory.

My TC is TC V5.0 Build 936 ACIS 18.0.2

Thanks.

Logged


* November 07, 2013, 01:29:08 AM
#3
TurboCAD 5 seemed to be "crazy" with saving files, constantly prompting about overwriting a file even though it had been the actual document that was opened.

After making edits and habitually doing Command-S, it would pop up the file dialog and inform me that the file exists, rather than just save to it like expected. Sometimes I ended up with stacked extensions on filenames too. All the drawings are done in thousands/mil, three digit decimal.

For exporting to lasercutting, that part has always worked. For my workflow, I would select the segments I wanted to export, use the export command, select DXF, Selection Only, DOS/Windows file format, and 1" = 1 Unit.

The pre-processing software and the laser cutter are on Windows 98 and DOS 6, respectively, (yes, old machine), the pre-processing is done using a Virtual Machine (VMWare) on the same Mac and the GCode that is created from that exported DXF is saved to a network share that the cutting machine has access to.

In closing, the import/export for DXF have never given me any issues, and with Version 7 it seems to work even better than ever.

Logged


November 07, 2013, 03:01:39 AM
#4
and your laser werks Ok without poly arcs?

Logged


* November 07, 2013, 05:28:27 AM
#5
arc-eye,

I would recommend completing a clean installation of the application and installing the latest build version of TurboCAD Mac v5.1

TurboCAD Mac Version 5.1 can be downloaded from the following link.

http://tcmacforum.imsisupport.com/index.php?topic=597.0

If you need the instructions on how to complete a clean installation please email me at Monizuka@imsidesign.com.

~monizuka

Logged


* November 07, 2013, 07:51:23 AM
#6
and your laser werks Ok without poly arcs?
Actually, my pre-processor hates B-Splines, though that looks very similar to a poly-arc. I just avoid B-Splines, and change them to individual arcs of any kind once the lines are settled on.

Logged


* November 12, 2013, 02:10:43 AM
#7
Hi Monizuka,

I completed the clean install, thanks for the help on that.
No change to the problem though I'm afraid.

Also I now seem to be on trial, and am not sure how to register.
I have a 16 digit code that came with copy of TC5, but the registration page is asking me for two codes, what am I missing here?

tdFTZ - thanks for that, I must admit  didn't understand all of it - I don't do laser cutting myself, just send the files off the the laser cutting company.

Thanks.

Logged


* November 12, 2013, 08:03:37 AM
#8
arc-eye,

When completing a clean installation the proper files were deleted? There should have been two file that needed to be deleted?

To activate the software a serial number and activation code will be needed.

When activation the software after entering the serial number the software will ask if you like to receive an activation code online.

~monizuka

Logged


* November 13, 2013, 04:00:38 AM
#9
Hi Monizuka,

I tried the clean install again.

Two files were deleted, but there was no Library File in Users/My Name

Library/Apllications Support/IMSI was in the Hard Drive folder.
TurboCAD was in Applications
These were the files deleted (I emptied Trash afterwards)

I activated the software successfully with your advice - thanks.

The issue with grouping seems to have been resolved, which is great.

The file is still corrupting somehow when exporting to DWG - sizes go all haywire, wether imported to TurboCAD or opened in AutoCAD.
I tried grouping the objects that were separating, but didn't make any difference.

I'll email you the two files (tc3 & DWG) so you can have a look at the difference.

Thanks.

Logged


* November 13, 2013, 07:38:28 AM
#10
arc-eye,

I have exported the TurboCAD v5 file to an .DWG drawing file and tested the newly created .DWG file in multiple version of CAD and have not been able to duplicate the issue reported.

When this drawing was create what units of measurement were used?

When the drawing was exported what units of measurement were used?

When the drawing was imported what units of measurement were used?

~monizuka

Logged


* November 13, 2013, 08:22:50 AM
#11
arc-eye,

The Library folder is hidden. In the finder menu hold the option key and click on "Go", the Library folder will appear in the dropdown about midway.

Enjoy
Mitch

Logged


* November 13, 2013, 08:27:03 AM
#12
Nice tip, Mitch, didn't know that.

Logged
Bob Borcherding
(using only 2D features at this time)
Mid-2010 Mac Pro, ATI Radeon HD 5870 1024 MB
2-1920x1080 monitors
6 core, 3.33 GHz
32 GByte ram
OS 10.8.5


* November 13, 2013, 09:22:17 AM
#13
mitchb,

Thank you mitchb forgot to post that in the previous post.

~monizuka

Logged


* November 19, 2013, 06:03:59 AM
#14
Hi There,

Sorry about the delay, I had to put that down for a bit…

I have now clean installed again, this time having deleted the file in the hidden Library (thanks mitchb).

I have now imported the DWG successfully back into TurboCAD, but think it may be because I wasn't selecting Turbo CAD in the software section of export and import before.
The problem persists when trying to export to AutoCAD however, so I can only assume it is something in the way I am exporting/importing.

I am doing this…

File, Export, Export Type DWG, DWG Format R12 (though I have also tried R13 and others), Units mm, Software Autodesk AutoCAD, DXF Format R12, Units mm.

What happens then is it tries to save the file but with a .unknown file type - which won't open or import into AutoCAD

I have AutoCAD 2013 by the way.

Thanks

Logged