TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Issues Reported in 1103 - Still Present in 1109
Read 6589 times
* April 03, 2014, 01:23:38 PM
Opening a file by double clicking or dragging to the dock results in extra layers added.

You must use the Open File dialog. Not everyone does this. It's highly un-intuitive and causes documents to be a big mess after successive openings unless the layers are not cleaned up, if one "forgets" to use the Open File dialog to get the document.

The "Window" menu still does not work right if all open documents are closed and the application remains open with no documents.

Steps to repeat:

Launch TCM7
Look at the bottom of the Window menu and notice "Untitled-1" at the bottom.
Create another new document. Now you will see "Untitled-1" and "Untitled-2" at the bottom.

Close both of them, so that the opened application only shows:

   TurboCAD Mac Pro 7 64   File

Create a new document and go look at the bottom of the Window menu. You will -NOT- see it listed there. Create a second, and the second will be listed. But not the first.

These issues have been brought up within the forum several times, but seemingly blown off. :(

Logged


* April 03, 2014, 01:48:09 PM
#1
Additionally, the Save function continues to prompt for a file name when used, resulting in extra dialogs that are not necessary, especially when you have the Save As menu item as well. They are essentially the same thing the way they act.

Logged


* April 03, 2014, 02:12:31 PM
#2
Groups are still screwed up.

Because right now:

I created a circle. Copied it three times, putting them in a triangle pattern.

Selected all three. Created a group.
The inspector shows I have 4 objects.

Copy the group again.
The inspector shows I have 5 objects.

Copy the group again.
The inspector shows I have 6 objects.

Copy the group again.
The inspector shows I have 7 objects.

Copy the group again.
The inspector shows I have 8 objects.

Delete the one that was number 7.
The inspector shows I have 7 objects again.

Save As .. the file, a different name.
Open that one. The inspector shows 13 total objects.

There are extra ungrouped circles under the group of three circles.

Groups are still screwed up.

The file I started with was called "Sample 5", the new file was called "Sample 7", now both of my opened documents are titled Sample 7. Yet as I mentioned before, only one shows up on the Window menu.

This update is no better than the last. The same added layers, the same group crap.

Yes, it says 1109 in the about box.
« Last Edit: April 03, 2014, 02:14:05 PM by tdFTZ »

Logged


* April 03, 2014, 02:36:29 PM
#3
The -ONLY- way to save a file properly is to use the Export as TCM 7 sp1 file with [X] Selected items only. 

Any other way will save a screwed up file if you even touched the group function.

This is also from a clean install, having trashed the old application and started over. I did not go clear out the stuff in /Library

Logged


* April 03, 2014, 06:08:15 PM
#4
tdFTZ,

Quote
I did not go clear out the stuff in /Library

Does this mean the com.imsi.turbocadprovESD folder was not removed? If so, it needs to be removed.

When TC is launched the first time this folder is created and populated with the current files. If the folder exists then it and its' contents are kept as is, leaving you running on the older info.

Enjoy
Mitch

Logged


* April 03, 2014, 07:19:48 PM
#5
Yes, that directory.

There's nothing in there but .ini files and the backups. There's no libraries, resources, code segments, etc. 

All of that was moved into the application package with version 7.

..and I renamed it so it would create it again, and it's still screwed up.

The file that is open shows 11 objects in the inspector window.
When I save it, make a copy of the saved file, and open that to compare with the opened file, I see 20 objects in the explorer.

In first screen shot, that's my "original" never closed file, you can see 11 items in the explorer.
The red group is selected.

In the second screen shot, that's the file after I saved, made a duplicate, and opened that. It shows 20 items in the explorer.
When I click the same location on this, you can see that there are the original circles that make up that group -and- the group to select from.

Seriously, how is this stuff tested? Why am I finding this, and a team of beta testers is not?

The only thing I notice that works in this build is being able to copy/paste text with the keyboard in the dialogs.

Everything else I've reported is still screwed up. Groups, File Save, Window menu.

Logged


* April 05, 2014, 10:19:00 PM
#6
tdFTZ,

I've been looking into this issue and have been able to duplicate it. Go to preferences -> Filing and check the "Clear Undo on Save" to fix it. What's happening is the original geometry created before the grouping and saving is being kept so you can "Undo" back before the last save, all the way back to the first circle if needed. This is a feature not a bug.

Enjoy
Mitch
 

Logged


* April 06, 2014, 12:12:08 AM
#7
I can't duplicate it.

I tried to follow tdFTZ's workflow and this is my report with a few clarifications:

Made new dokument

Created a circle. Copied and pasted it two times, putting them in a triangle pattern.

Selected all three. Created a group of them.
The Layer palette showed I have 1 item in "Layer 1".

Copied and pasted group.
The Layer palette showed I have 2 items.

Pasted the group again.
The Layer palette showed I have 3 items.

Pasted the group again.
The Layer palette showed I have 4 items.

Pasted the group again.
The Layer palette showed I have 5 items.

Deleted the one that was number 4.
A dialog appeared that said "Object to delete has dependencies..." which I didn't understand in that context.
Answered Yes on the question if I want the dependencies removed.
The Layer palette showed I have 4 items again.

Saved as "a_aa.tcd" on Desktop.

Opened the same file without closing first
Two windows appeared with the same file name. Which are a very odd behavior. Only one of them was in the Window menu.
The Layer palette still showed I have 4 items in both windows.

The "Clear undo on save" was checked.

So. Am I missing this "feature"?

Regards

Logged


* April 06, 2014, 03:41:28 AM
#8
In the version 1103 my biggest problem was the instability of the groups.
When you used them saved the drawing and reopened sometimes the groups duplicated across your drawing. Is this issue solved? To the programmer look at the code of sketschup it shouldnt be to hard to fix it.

Logged


* April 06, 2014, 06:49:21 AM
#9
This is a feature not a bug.
Seriously? A -feature- that -ADDS- extra elements to your drawing, that increases the item count?

That's not a feature, that's a -MESS-

If they remained invisible, tracked only by the application, and not a factor in editing then I would absolutely buy this as being a feature. As for the preference to clear undo at saving, I can see exactly why it solves the problem. But it's still got behavior that is counter productive.

Come on? Really? Those elements are not present when the drawing is being worked on now, If I select that group, I get -that group- and nothing else. When I save it, and reload it, now if I want to move that group I have to move that group and three other items.

That's not a feature, thats making me more work.

That's still a bug. If it's saving undo work with it, then the elements for undoing should be invisible. They should not suddenly become visible parts of the drawing.

Because when I output that as DXF, guess what? I've got SIX circles there now, instead of three. That means the CNC machine is going to make two passes on each.

Also:

Version Six does NOT do this, even with "Clear Undo On Save" unselected. Version Six handles it properly, the undo items are held invisibly.  Your suggestion is a fix, to cover up a bug.
« Last Edit: April 06, 2014, 06:58:37 AM by tdFTZ »

Logged


* April 06, 2014, 09:57:21 PM
#10
jolbas,

That is the same behavior that I observed, with "Clear Undo on Save" checked you can't undo back past the save, if it's unchecked then you can. That is what I referred to as the "feature" being able to undo back past the save if you need to.

Enjoy
Mitch

Logged


* April 06, 2014, 10:58:33 PM
#11
Yes, you may call it a feature, and if it worked like TCM6 does, you wouldn't need to be selecting UNDO on Save.

But this way, it's still clearly broken, and clearing it on save is simply a false fix. In TCM6 the elements remain invisible unless recalled. They don't re-appear in the item count, in your workspace, as elements you have to move around. That is a bug.

Logged


* April 07, 2014, 01:38:46 AM
#12
The bug in V6 is unchecking "Clear Undo on Save" is not working, even with it unchecked you still can't undo past the last save. At least my build (987) doesn't work. Check your version and see if you can do it.

Enjoy
Mitch

Logged


* April 07, 2014, 03:42:49 AM
#13
The undo stack has never supposed to be saved. "Clear undo on save" sets what it sounds like.
When its checked it clears the undo stack when you save and then it is not possible to undo to a state before the last save.
When unchecked you can undo back to the state of the document as it was when you opened it. Never further.

Logged


* April 07, 2014, 07:09:21 AM
#14
Going on what Mitchb said first:"
What's happening is the original geometry created before the grouping and saving is being kept so you can "Undo" back before the last save, all the way back to the first circle if needed. This is a feature not a bug.
Perhaps it's -meant- to be a feature, but it's still not working consistently.

When I start a document and make changes, the things I deleted are -INVISIBLE- to me. For all intents, they are gone. But yes, I can go back and undo all the way back to the beginning or however far back that audit trail is saved.

So, if I save my work, close the document and come back later.. when I saved it, those items that are held in the undo history for me are still invisible. That is they are not anywhere where they will impact my drawing. If I select that group, I get that group. Period.

Now I've reloaded that document and when I go to select that group I am prompted if I want to select that or one of the circles that are hiding under it.

Those circles are -HISTORY- items, not items in the present. They were not visible, manipulatable, selectable, or ANYTHING right before I saved it. Why should they be anything more right after loading the document again?

The document should be reloaded in -EXACTLY- the same state it was saved in.

No extra layers created, no items suddenly re-appearing, even though they are completely hidden by other objects. None of that. The application should not be modifying the state of the document at all.

No other application does this. Some may indeed save history along with the document so that undo's are possible prior to the document state during that session, but those changes are not suddenly visible.

Take your own wording and apply that to a Word Processor document. If I were writing something and replaced the whole second paragraph before I saved it, yet I can UNDO back to that original second paragraph. Now when I reload that document, would it be acceptable for me to find the original second paragraph text visible again?

In Photoshop parlance, the history of edits is just that. History, and not visible ever again unless specifically called on. Save it all you want. But not make it visible.

To be honest, I never realized that the ability to undo past the point of which the document was last opened, and would have not even expected it. In that regard, V6 works exactly as to be expected. Without selecting "Clear Undo at Save" to gain that behavior. OTOH, V7 needs to have it selected, so that negates that issue for me, but it does not solve it.

Logged