TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Controlling the transparency of a 2D object
Read 140 times
* August 04, 2017, 02:33:47 PM
Can someone tell me how to set the transparency value of a 2D object, one that has a particular fill that I have chosen from the fill pattern menu in Inspector?
Thanks in advance

Logged


* August 04, 2017, 05:38:22 PM
#1
There isn't any way to set the opacity of a filled polygon that I know of. To see objects behind a fill, use the "Edit" -> "Arrange" -> "Bring to front" option.

Enjoy
Mitch

Logged


* August 05, 2017, 09:46:02 AM
#2
Thanks Mitch,
I saw this link and it made we wonder if it was possible.
http://www3.turbocadcommunity.com/tiki-index.php?page=2D+Transparency

Logged


* August 05, 2017, 09:09:24 PM
#3
The windows version is quite a bit different. We can control the opacity of solids and surfaces but not filled polygons.

Enjoy
Mitch

Logged


* August 06, 2017, 05:40:28 PM
#4
Doesn't a filled polygon act as a solid if it's a solid color? What kind of solids are you talking about then?

Logged


* August 06, 2017, 10:46:34 PM
#5
A solid is an object that is 3 dimensional. A filled polygon has no thickness and thus not a solid. Solids and surfaces, though not a solid, can have their opacity controlled using the "Shade Options" palette after "Transparency" is checked.

When I use the term "polygon" in reference to this program, I'm talking about "Smart Polygons". If you set the rectangle tool to "Single Line" and draw a rectangle the inspector in the title bar will call it 4 line. But do the same thing with "Smart Polygon" selected and the Inspector now says "1 Polygon". Also be aware that if you fill a "Single Line" rectangle a new "Smart Polygon" is created on top of the four lines and it is this polygon that is filled.

Enjoy
Mitch

Logged


* August 07, 2017, 09:39:53 AM
#6
Mitch,
When I draw a smart polygon, my inspector window does not look like your picture. I am only seeing data and attributes, no display and hence no option to check transparency etc.

Logged


* August 07, 2017, 10:02:16 AM
#7
Look at the inspector title bar and see that it says "1 Block" indicating that the solid block is selected. Solids and surfaces have a transparency option which then allows an opacity setting. Filled polygons do not have this.

Enjoy
Mitch

Logged


* August 07, 2017, 01:30:21 PM
#8
Working good, thanks Mitch!

Logged