TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Beach ball of doom
Read 1439 times
* January 30, 2017, 01:40:29 PM
#15
Thanks for your input Matso,

I will address each of your points with results.

"Save Preview Image" Unchecked and done
"Undo on Save" Already unchecked
Corrugated Iron; I have this shape on a separate secondary layer under Roof. I have noticed the drawing takes a little extra to load this layer and to redraw it each time I move it about. Unless I'm working with that particular layer I don't have it in view. It doesn't seem to make any difference, I could be working on a single layer of the simplest part and the beachball will start up and halt work until its finished its auto save. I don't dare uncheck auto save as I've had drawings corrupt before V9 especially and not being able to access the drawing after weeks of work is sole destroying.
"User Groups-log in items" nothing in there checked and I'm the only user of this computer or home network.
"Run Disk Doctor" don't have this app. I did run Disk Utility - First Aid, see the screen grab below. It asks me to run first aid from Recovery. I try click on recovery but will not open, the button isn't even available to click on. The only buttons that are available to click on are "First Aid" and "Info" I don't know how to do this.
"Rebuild Disk Permissions" again that sounds like whitemans Voodoo talk there. I would need a more descriptive explanation there more like how you described User Groups - logins description.

As I have said in earlier posts I run the internetand have a page or 2 open for reference photos and possibly an open image in preview. Nothing downloading or active while I'm drawing. I have tried shutting everything down and only having the drawing open, with no success.

Thanks again I'm grateful for your input, I would like to get to the bottom of this corruption that the First Aid app has found.

I have added another couple screen grabs to show that I have plenty of RAM to run the document drawings. See drawing info and About Mac
« Last Edit: January 30, 2017, 01:45:41 PM by Baggyarse »

Logged


* January 30, 2017, 09:17:26 PM
#16
I agree with all that matso says. Saving every 10 commands and 10 minutes is a bit much, I use 60 commands and 90 minutes and I'm comfortable with that. The facet count is a product of the cylinders and roof design
 
How big is your file and how much memory do you have? Given the number of objects and what kind they are your system should be pretty responsive, the low memory has me baffled. How much free memory does an empty drawing show? Just launch TC and in the verify menu -> Objects Count, how much is free? Mine shows 3386.0. Still trying to figure if it is a problem in your system or TC.

I now see your last post. 170 MB looks way to big a file with so few items, Have you used "Compact" in the File menu? The file that I posted above with 13,208 solids is 40.1 MB.

Quote
"Rebuild Disk Permissions"
is not available in OS Sierra. To repair a system disk you need to start up in "safe mode".
 
Enjoy
Mitch
« Last Edit: January 30, 2017, 09:36:45 PM by mitchb »

Logged


* January 30, 2017, 11:10:14 PM
#17
Hi MitchB,

Yes 10min every 10 commands is a bit excessive but I recon it should still be fster than it is and thats how paranoid I am of having a file corrupt. I will back it off to 20 commands every 20min.
I opened object counts on an empty page, see below attachment. 2511 on the "free" line.
There is no option for "compact" in the file menu. I shouldn't have to use this though for such a small file. I suspect the problem may lie in the corrugated Iron profile somehow. I need to find perhaps a TC formatted 3" corrugated iron profile. Is there a place I can go to download various building material profiles in TC format. I reckon somebody from TC will have to go through the file/drawing it and take a closer look.

Logged


* January 31, 2017, 03:56:09 AM
#18
Hi Steve,

Sorry, my bad - Disc Doctor is now called Disk Utility in OS X Sierra and "Rebuild Disk Permissions" has been integrated in "First Aid" as far as I understand.
https://support.apple.com/en-bn/HT201560

Rebuild Disk Permissions is a standard housekeeping chore (or was until Disk Utility came along) that I've used for eons. As it's no longer part of the MacOS I use CleanMyMac and Rebuild Disk Permissions manually each and every time before I restart my computer when using TCMPro. I don't know if it affects the TC files or application, but better safe than sorry. BTW, CleanMyMac is a great program to get rid of junk on your computer. http://macpaw.com/cleanmymac

IMHO autosaving that often is overly paranoid, although I've had file corruption a few times and lost a lot of work. (Frustrating yes, but not all bad though, as redoing some items causes you to think and sometimes come up with better solutions).
As mentioned previously, I don't want to get interrupted by autosave as it disturbs the creative juices ;D. Instead I created a workflow where every day I go File>Save As... and create a back-up copy of my file on a separate hard drive. I then go back to work on the original file. Should that file get screwed up I haven't lost much... Daily works for me, but any time period would of course work...
Also make sure your file lives on the computer hard drive or one attached by a fast connection (like USB 3 or Thunderbolt). If it lives on say Dropbox or a USB 2 HD you'll get slow saves...

File>Compact... is in TCMPro, don't know about DeLuxe which you have, right? I haven't used it for some time, but just did - reduced my 578 Mb file to 155 Mb!
Update: Well, that did no good, deleted a whole bunch of objects so no wonder the file size reduced. Obviously this command does not work as it should - back to the original file. Sorry if I caused any confusion.

Be all that as it may, you may have the problem I've encountered a few times now when TCM has misbehaved - a corrupted object in your drawing. Recently I experienced lots of hanging, crashes etc - very frustrating. Finally traced it to a CAD object that I had imported and that had been in my drawing for a long time. For whatever reason it became corrupted and screwed things up in a big way. Once removed all problems seized and all was good again. I then re-imported the same item from the same source, pasted it in place and everything was still fine - go figure!

To find such a culprit I'd suggest turn on half of your layers (and sublayers) and see if your problem continues. Then turn off that half and turn on the other half and see if there's a difference. Whichever half is worse, divide that in half and find which half is giving the problem. Continue in this fashion until you find the culprit layer(s). Once you find the layer, check all objects in that layer for corruption and/or delete them.

Corrugated Iron profile - it's not that complex and you can probably create it yourself if you don't find it online. I usually download .stp (STEP) files which import fine into TCM, once opened in TCM use File>Save As... and voila its a tcp file!
Good sources for CAD objects (mostly free):
https://www.mcmaster.com
http://www.tracepartsonline.net
https://grabcad.com/library

Finally, make sure you don't have MacKeeper on your computer! It's a nasty piece of malware that is not uncommonly hiding in the deep trenches of many peoples system. Use Spotlight (the magnifying glass icon in the top right corner of your screen) to search for it - if you find it google "complete mackeeper removal" for the specific procedure as just deleting what you find is not sufficient, it has a bunch of hidden files... nasty shit...

Cheers,

Mats
« Last Edit: January 31, 2017, 04:19:43 AM by matso »

Logged


* February 03, 2017, 11:16:12 AM
#19
One other thing to look at: Run the Activity Monitor but click on the "Memory" tab rather than "CPU" - this will show you how your RAM is being used (or used up).  There will be a graph at the bottom showing "Memory Pressure", which I suspect is another way of referring to free space; if it's anything other than a green bar at the bottom then you should add more RAM to your computer.

Logged
>>Computers were invented to help people waste more time faster<<


* February 14, 2017, 05:10:43 PM
#20
@ khillig,

Have a look at this screen grab of the Activity Monitor while the TCDv10 is unresponsive. I'm trying to use this program to make products to sell. It's killing time in an already labour intensive process.

« Last Edit: February 14, 2017, 05:19:47 PM by Baggyarse »

Logged


* February 15, 2017, 12:20:08 AM
#21
You should have more than 15% of free disk space and you are right at that now. Do you have some stuff that can be removed or moved to another drive?

Have you installed version 1321 yet?

Have you been able to run first aid from safe mode yet? Google "Safe Mode" for instructions.

Your Swap Used: stat is very high <100MB is considered okay.

Google slow macs, there are lots of ideas to try and other information on the subject.

Enjoy
Mitch

Logged


February 15, 2017, 09:36:50 AM
#22
A simple question.?
May be already answered but then I was loken over.


Wich OS are you running ??  El Capitan or Sierra.??

I have simular problems, but with other programs like Safari reporting "not respondent"  and then a beach ball always running.
with at the end a warning taats I run out of memory.
This problem arose since the last update from 10.12.2 to 10.12.3


I forgot.
In my case
 you open activity monitor and look at memeory. Then you open safari.  Do noting any more and watch how safari   build up using memory. until it is at 14.85GB of 16GB  or as virtual memory of 43.95 GB  . then I got the waring.
May be this happens in your system bthe same but with Turbo Cad

« Last Edit: February 15, 2017, 09:42:36 AM by beagle »

Logged
As you get older, everything become worse, except for the oblivion, which is getting better and better ...

Beta tester- EazyCNC


* February 19, 2017, 03:16:24 PM
#23
Thanks for all your assistance but it appears nothing is working.

I have large file sizes yet I have simple drawings, I have seen screen grabs of others drawings that are way more complicated than mine with smaller file sizes. I don't understand that.

@ mitchB; I have had a look at one of your posts with the screen grabs of your drawings and object counts. It appears there is a clear difference between the performance of your older 2008 model and my 2013 model. You have far more available memory than I do and your drawing has more objects, same amount of Ram but I should have a more powerful processor.

I have the IMSI team having a look at it. I cannot use the program once the drawing gets to a certain size as it appears the processor can't work fast enough.

Does Turbo Cad use the processor as efficiently as it could do? Does it use all the cores?

Does anybody else use a notebook for doing their drawings on or does everybody use a desktop computer. Below is the specs of my computer.

Hardware Overview:

  Model Name:   MacBook Pro
  Model Identifier:   MacBookPro11,1
  Processor Name:   Intel Core i5
  Processor Speed:   2.6 GHz
  Number of Processors:   1
  Total Number of Cores:   2
  L2 Cache (per Core):   256 KB
  L3 Cache:   3 MB
  Memory:   8 GB
  Boot ROM Version:   MBP111.0138.B21
  SMC Version (system):   2.16f68
« Last Edit: February 19, 2017, 03:29:40 PM by Baggyarse »

Logged


* February 20, 2017, 01:34:37 AM
#24
Hi Baggyarse - still laugh everytime I see your "handle"...

FWIW, I've got a pretty large and complex file that I've been working for some time now, starting in TCMP v8 and now working in v10. File size is currently 600 Mb and growing by the day. I have not seen any slow downs and annoying beachballs for some time, unless I've got a corrupted object in the drawing. I think I've mentioned this before to you...

I did have extensive speed issues in the past, similar to what you're reporting, with earlier versions of the same drawing. Naturally I cursed the program and started looking at alternatives... IMSI Tech support couldn't help (just said they've never seen such a large file) and sent the issue directly to Tim Olson, the guy writing the code. He's been a life saver - supplied some new builds that fixed the issues, supposedly with the help of my file. (Most other bugs remain however, but that's another story...). I can only hope you will see the same result eventually.

I've also often wondered if the program actually uses all the horsepower available of the computer. As mentioned earlier, I've never seen more than 20-25% usage of all the cores when using the program (using the program "iStat Menus").

Your MacBook is slightly slower than mine and have only half the RAM. However, I run the program both on my 15" MacBook Pro 2.5GHz i7 & 16Mb RAM and my superfast, special order 27" iMac 4GHz i7 & 32 Mb RAM - for the life of me I cannot see any difference whatsoever in the speed of the program between the two computers (with the same file). The main benefit with the iMac is the amazing 27" retina screen. It's a completely different experience than working on the "postage stamp" size window on the MBP, especially if you have a lot of toolbars visible (as an earlier screenshot of yours indicated...).

8 Mb RAM may be a little low, and as others have suggested you may want to try upgrading to more. Or try your file on a faster Mac - bring the file to your nearest apple Store or reseller and give it a try.

My two cents worth as mentioned earlier is that you likely have corrupted objects in your drawing. If the drawing is "simple" as you say, try recreating it and see if the issues remain. Yes, I know it's not a happy prospect to re-create, but if as you say it's a simple drawing, it may be a more productive course of action than continously tearing your hair out.

Cheers,

Mats
« Last Edit: February 20, 2017, 05:54:43 AM by matso »

Logged


* February 20, 2017, 03:15:59 AM
#25
@ mats,
Where do you get 8Mb ram from? Do you mean 8GB ram? Is 8 GB low? it seems like a lot to me.

I have the same issue with all my drawings it seems as the each drawing gets bigger it starts to slow down. The drawings arn't even that big. Small really. yet the file size is large. why? I have about 4-5 drawings that I can't work now cause they just take so long to save, and now the computer crashes on a couple I've had files corrupt a few times so far because it crashes while saving. I need to finish my drawings off so I can get my models to shapeways. I need to get prints back before mid march. This whole trouble shooting process on line is taking too long and the IMSI team are very slow in getting back to me and I don't think they are very interested to tell you the truth. I don't have the time to relearn another drawing program. I'm really quite pissed off with the whole ordeal now.

Logged


* February 20, 2017, 06:16:04 AM
#26
Hi Baggy,
Yes, of course I meant 8Gig RAM  ;D - sorry my typo. Buy it from any reputable computer vendor, just make sure it's for your flavor of MacBook as there are slight differences... You can install it yourself (google for instructions), or have someone do it for you...

I'd say 8Gb RAM is plenty for "normal" computing, but CAD work is graphics intensive so more is better IMHO... although as I mentioned, I don't see any difference working on my MBP or iMac...

Check if IMSI support has sent your issue on to Tim Olson, if not it will likely unfortunately be forever till you get resolution from them  >:( - they're a marketing company, reselling a version of ViaCAD. In my experience (and many others here on this forum)  they have very limited in-house tech talent and rely on people like "mitchb" here on this forum to keep them from going out of business due to poor tech support...

Did you try to find corrupt objects in your file using the method I posted earlier?
If not finding any it could be that you need to do a clean re-install of your MacOS (not from a backup) and then reinstall TurboCAD (latest build, not from a backup!). Not often that MacOS gets screwed up, but you never know with the issues you're having, it could be a factor...

I can relate to your time constraints to complete the project and get it out to the customer. Most of us who do this for a living have similar issues, and it can be extremely stressful when things get this buggered up.

Cheers,

Mats

Logged


February 20, 2017, 09:20:07 AM
#27
In this concern.

As I have a similar problem but in my case with “Safari” and not with TC. During now more than 2 weeks
Finally ,  I had run anti virus scans,  Mal ware scans, adware scan etc…
And the problem was still there.

Finally I have done a Format of the SSD drive, followed big a clean install on Sierra. Not that al the other software was not installed. No restore from Time-machine.
So I have installed each application from CD and/or from download at the vendor.
In that Time I had observed the behaviour of “safari” . And he performed like normal.

Finally I have only restored my personal files from Time-machine.and all work not very fine…
As test I have loaded TC-pro V10 and loaded an example file.
The activity-monitor shows.:
Turbocad memory 117,3MB
Memory used = 3,79 GB. Out of 16 GB.
Cached files 2,81 GB

Conclusion… some file in the “Library” and in the User/library must be corrupted.

I know it is a lot of work, I spend 1 day on it. But  I think you must consider a reinstall. Is better than trying and trying and debugging etc..
I ‘m Happy that I have done it.

Logged
As you get older, everything become worse, except for the oblivion, which is getting better and better ...

Beta tester- EazyCNC


* February 20, 2017, 05:04:44 PM
#28
The only part of TurboCAD that uses multiple cores is in photo rendering to the best of my knowledge.

Page 465 of the V10 User Guide:

Quote
Multiple Processor Rendering
PhotoRendering supports multiple processors when using the photorendering command. You will see multiple scans based upon the number of processors.

Page 451 of the v10 User Guide:

Quote
Multiple Processor Rendering
TurboCAD Mac Pro supports multiple processors when using the photorendering command on Mac OSX. Additional processors are automatically enabled if you have a dual-processor Mac.

I'm using a 15" MBP, an old one 5,1 late 2008. To old to upgrade to Sierra so I'm looking to get a new one.
8 GB memory
2.8 Ghz, core 2 duo

Crashing while saving is a sure sign of corrupted objects in your drawing, the bigger question will be how they have become corrupted. Since you have IMSI looking at your drawing I hope they will be able to answer these questions.

Enjoy
Mitch


Logged


* March 05, 2017, 03:14:47 AM
#29
Ok latest update is that Tim Olsen is now on the case.

He has found an issue that I'm having with my version TCDV10 build 1317 he writes; "It appears Deluxe is building a history tree causing the file to be larger than it should. I've compacted out history in the attached zip."

The returnerned zipped file with the compacted history tree runs nicely so far but all I have done is open and shut layers, but its miles ahead of where I was with it previously.

I don't know if this is an isolated case with me or an issue with this version. Heard nothing more as it's a weekend. I await more news after they poke and prod the captured offending drawings I supplied. Hopefully they supply a patch or some sort of a week somehow as the program is still creating large files with each new drawing I do.

I'm finding it easier to work if I create new drawings for different aspects or variations of my drawings rather than just creating more layers. Bit annoying though when it come to working between variations to create another have to have 2 drawings open rather than opening and shutting layers.

Once again thanks for your offers of assistance.

Logged