TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Hatch Issue
Read 324 times
* February 08, 2018, 12:27:01 PM
How do I draw objects so that they appear inside a rectangle that has been filled via hatch. I tried bringing the objects forward but that didn't do it. I want a rectangle that has been filled with a particular color to not hide subsequent objects that I draw inside it.
Thanks

Logged


* February 08, 2018, 11:38:20 PM
#1
A fill and a hatch are very different entities. A hatch is inside a single line polygon but a fill is associated with a smart polygon. If you use the fill tool to fill a single line polygon notice that a smart polygon is created to contain the fill so you now have two rectangles the original single line and the smart polygon. A smart polygon will not hatch.

A fill is always on top. To show the objects under the fill select the polygon and set "Show Fill" to No, then select everything inside the smart polygon, then select Edit -> Arrange -> Bring to front. Select the smart polygon and set "Show Fill" to Yes. The fill should now be in the background. If you continue to add more geometry it will also need to be selected and the "Bring To Front" will need to be applied.

Enjoy
Mitch

Logged


* February 12, 2018, 08:51:57 AM
#2
Thanks Mitch
On another note, it looks like I can export a 3D pdf file but not a 2D?

Logged


* February 12, 2018, 12:11:46 PM
#3
2D PDFs are saved through the Print menu. After you have set up your drawing for printing just select one of the PDF options from the Print menu box.

Enjoy
Mitch

Logged


* February 13, 2018, 10:50:02 AM
#4
Mitch,
I am having quality issues with doing that, creating a pdf from the print menu. Also when I create a jpg using screen shot and then export the jpeg into preview and then into a pdf, the quality is substandard. I just starting having this problem and it makes it hard to get nice quality pdfs to customers. The export function in TurboCAD seems to produce a higher quality pdf for some reason that's why I asked. Do you have any other suggestions that might work?

Logged


* February 13, 2018, 09:24:10 PM
#5
Quote
I am having quality issues with doing that, creating a pdf from the print menu.
Quote
TurboCAD seems to produce a higher quality pdf for some reason that's why I asked.

Not sure what you mean by these seemingly contradictory statements. Can you post a sample drawing for us to test with?

The pdf code used by TC and Preview are both by Apple. Jpeg is a lossy format and every time you export/import then convert you can expect even more loss. Preview does have some control over the amount of loss when saving. I have no idea what quality ScreenShot uses.

If I had a drawing I could look at the settings to see if I can make a clean pdf.

Enjoy
Mitch 

Logged


* February 14, 2018, 01:13:01 PM
#6
Mitch,
I have attached the TurboCAD drawing file and the pdf that I created via the print menu. See the "k" in Viking and the 1/2"= 1' that have
been altered. In earlier conversions of TurboCAD files to pdfs, I have seen text that lack sharpness. This test not so much. I basically would like the highest quality reproduction that I can get when converting to pdf.

Logged


February 14, 2018, 01:29:56 PM
#7
That is kinda wild lookin= opening my "new" V10 to test

Logged


February 14, 2018, 01:53:13 PM
#8
This iz quite interesting! when on the ISO ( Aero) setting, I got that wierd letter K, but my PDF is OK! I did click my active layer to Construction, hid the solids, and the curves from (my) side view not on the z plane, then set up to print

Logged


* February 14, 2018, 10:40:07 PM
#9
This is an issue with the print method rendering the font. Looking at the print preview window you can see the strange K along with the boxes in front of Scale. I deleted the "Times New Roman" font and replaced it with "Times" and it cleaned that up. I was not able to get the polygon pattern to  show up just the black stripe.

Do the 3D elements belong in this view? They look out of place here.
 
Enjhoy
Mitch

Logged


* February 15, 2018, 05:57:38 PM
#10
I have been doing some follow up work on your drawing and have found that hiding all the 3D elements in your drawing allows it to print/save as a pdf and allows the fill pattern to display. There is a transparent solid over the "scale", be sure to hide/delete that too.

Enjoy
Mitch

Logged