TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

How to keep objects in the same plane
Read 748 times
* March 27, 2018, 11:53:01 AM
Problems keeping multiple objects on the same plane. After creating a 3D object in say a front view, additional objects that I draw or add to that object are out of plane. How do I keep all the additional objects that I draw in the same plane as the initial object no matter the view type? I already have snap to plane checked in preferences.

Logged


* March 28, 2018, 12:12:47 PM
#1
Please post a sample drawing. I'm not sure what you mean by "out of plane".

Enjoy
Mitch

Logged


* April 14, 2018, 02:30:30 PM
#2
The question is probably answered in the documentation straight up .. except what we've got is a terminology problem with interpreting what we're looking for.


Start a drawing in Top View:

Put down three items. Whatever. Three, four, of anything.

Change views, look around, zoom in, out, all that kind of stuff that gets done during a session. Spend most of your time in a particular view, drawing, editing, moving your items and when it's time to go to the Push/Pull, Extrude, you see stuff "all over the place"

Code: [Select]
       Top View        Bottom View       Side Views (Should be)               
          A                A                                                                                                                             
            C                Ɔ             A C D E F   (Front)           ᖷ Ǝ ᗡ Ɔ A   (Right)                                                                                                     
              D                ᗡ           ᖷ Ǝ ᗡ Ɔ A    (Back)           A C D E F    (Left)                                                                                                                                           
                E                Ǝ                                                                                                                                                           
                  F                ᖷ                                                                                                                                                   
     Except for the Side Views, you really see:

          A                      A       
                E                  Ǝ       
              D              ᗡ
            C     F            F    Ɔ

Logged


* April 15, 2018, 12:29:53 PM
#3
I assume you are showing views as listed under the View menu and not orthographic projection views. Text placed in a top view will only show as a straight line in front, rear, right side, and left side views because you are looking at it edge on. In my examples, I typed in a top view and switched to a bottom view then isometric. In the fourth view, it is still isometric but I changed the height (Z-axis) above the work plane for some letters. After making these height changes the top view will not change at all because the top view does not show any depth perception.

Logged


* April 15, 2018, 06:06:56 PM
#4
My example is a time compressed scenario so yes, these are representing view selections from the menu options. Each letter would be a separate object. The sum of all of them being after some time of working with the document.

What I'm trying to convey is that in the first 6 view examples, what I see is correct, to be expected.

Where you say "after making the height changes" is the problem. I expect them to be all the same height when looking at any view where the Z axis is visible.  As in the top and bottom views will appear "flat"  but any side views will appear with the objects at random heights.

The X and Y positions are where I expect them, but the Z position varies for each one when you would expect that it shouldn't. As in, you had to make the height changes where as the opposite is my experience. I've got to move it all back to the same plane. As in put them all back with a Z value of 0.

How to say it..  Disregarding any orthographic views, concentrating on only the cardinal selections from the menu, where X and Y are visible and Z would only be visible in the two dimensional sense that if I had multiple objects at the same X,Y one of them would be above or below the other and that would be visible when the Z axis is visible, (any side view selected), otherwise one is obscured by the other when viewed from either the top or bottom.

In that scenario, you've been working on said drawing for "a while" and when you go to start working with it where you're going to start making solids, extruding faces on those 2D shapes and that first time you switch to any of the sideways views, you're expecting all of the objects on the same level and they are -NOT- .. How did they get "all over the place", when they shouldn't be?

Logged