TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

Line Styles
Read 412 times
* August 19, 2018, 09:06:11 AM
Hi, I have version 7.  Opening Inspector, under "Line", then "Style", I have the usual line styles that the programme is supplied with and then, under the line under "Custom", a load of line styles that are to do with drawing aeroplanes.  I can't remember how I managed to load them in the first place and cannot see how to delete them now.  I think when I loaded them there were other choices I could have made, but maybe not, can't remember!  I would like to delete them now though but the "delete" option does not seem to apply here.

Can anyone help with this?

Chris

Logged


* August 19, 2018, 12:10:21 PM
#1
To delete a custom line style it must first be selected (screenshot 1), then click on delete (screenshot 2). The built-in styles cannot be removed.

Enjoy
Mitch

Logged


* August 20, 2018, 10:06:38 AM
#2
Hi Mitch, that's what I understood to do, but for some reason only two of the aero linestyles have been able to be removed in this way; the rest when selected seem to show a linestyle but the style name remains 'custom' and nothing gets deleted when the delete option is pressed. Perhaps I have a bug on my MacBook.

And I still don't have a clue as to where the aero linestyles were sourced from in the first place - any help there?  Was thinking if they came in as a "job lot" I could delete them as a "job lot"?

Chris

Logged


* August 20, 2018, 05:29:50 PM
#3
When a line style is deleted the only data item that changes in the palette is the name goes to "Custom". You must now select a new line style either to use or delete. Custom line styles are saved with the drawing. Launch TC without a drawing and look at the line styles, you should only see the default styles available. Open a drawing that has custom styles and they will be loaded with the drawing. Opening another drawing that does not use the custom styles or starting a new drawing does not erase them. They will persist until the program is shut down and re-started or selected and deleted. After deleting custom styles from a drawing you need to save it or the custom styles will remain.

Enjoy
Mitch


Logged


* August 22, 2018, 07:52:13 AM
#4
Hi Mitch, sorry, been away for a couple of days.  All that you said makes perfect sense, so I can go on that.

However, I must have loaded the aero linestyles from somewhere within TurboCad, but I can't see where, don't have a clue.  I bet there are other sets of linestyes there too - if only I could find them?  In Applications I did a control-click on the TurboCad app to show contents, but didn't see it there, so at a loss to figure where it might be.

Can you point me in the right direction please?

Chris

Logged


* August 22, 2018, 11:02:22 AM
#5
I don't know of any line style file or folder, there is a pattern file that can be modified. To change that go to the Applications folder and right-click on the TC Icon. Click on "Show package contents", double-click on "Contents", "Resources", then "Environ". Open CADD.LIN file in a text editor and make any changes there and save it. As soon as you make the first change you will be told you don't own the file and must edit a duplicate. Click on duplicate and make the changes, save this to your desktop and close the original and duplicate files. Drag your new file into the Environ folder and replace it, you will need your system admin password to do this.

Enjoy
Mitch

Logged


* August 22, 2018, 12:51:36 PM
#6
Hi Mitch,

That's bizarre, as I must have got the aero linestyles from somewhere.  Ho hummm, must be one of those computer mysteries that are placed there to trap us un-computer-savvy oldies, thanks for your advice and info anyway,

Chris

Logged


* August 22, 2018, 01:04:04 PM
#7
Chris,

Did you make a "startup.dat" file? There is a third party aero package, did you install that? Could you post a screenshot of your line styles or a drawing that has the line styles for me to look at? I would like to dig into it to see what is going on.

Enjoy
Mitch

Logged


* August 22, 2018, 01:55:13 PM
#8
Mitch - I wouldn't know a "startup.dat" file if it hit me in the face let alone make one.

Hopefully I can add a screen shot:

Chris

Logged


* August 22, 2018, 02:00:03 PM
#9
And even maybe the drawing.  No, I don't have any 3rd party aero files on my computer, to my knowledge!
This is the drawing that the screen shot came from
Chris


Logged


* August 22, 2018, 02:39:23 PM
#10
Chris,

I see that your drawing was created in V9 deluxe. I don't have Deluxe but I do have V9 Pro, so using that, I was able to delete all the custom line styles. I then saved the file and re-opened it to verify that the custom styles were gone. My screenshot is of the saved file re-opened to show the custom styles are gone. If you are still using V9 Deluxe there might be a bug in that version or have you upgraded to a newer version which may have a bug?   

Logged


* August 23, 2018, 01:21:10 AM
#11
Hi Mitch, yes, now I have been able to do the same with that drawing.  I have another drawing with where I could only remove the first 2 custom styles and then it would reveal the name of any more styles (even though it showed a change in colour and pattern) so would not delete any more custom styles.  I upgraded last year to a more modern version of V7 De Luxe - V7.5.3 (build1109), and I think there must be a bug in there as I get the one or two other odd 'funnies'.  I am still on macOS Sierra and will need to update to V10 I guess to go to macOS High Sierra, so hopefully the bug will go then. 

Thanks for all your help - much appreciated,

Chris
« Last Edit: August 23, 2018, 01:23:28 AM by Chris2017 »

Logged