TurboCAD Mac Forum

Register
 
New TurboCAD Mac 2D/3D Training Essentials

svg export
Read 34 times
* December 04, 2019, 11:49:30 AM
Unsucessful in exporting 3 files to .svg format with new v11.
File 1 lost 30% or so of the lines.
Files 2 and 3 the resulting .svg file had nothing.
Confirmed this by importing back to TurboCAD and opening with Firefox.  Same result both methods.

Logged


* December 04, 2019, 09:15:34 PM
#1
Can you post a sample TC file for testing? I would like to save it as svg to see the result.

svg file format only supports 2D elements, not groups or any rendering. As an example, my screenshot 1 is a tcp drawing that I exported as an svg format and screenshot 2 is what it looks like in Safari.

Enjoy
Mitch

Logged


* December 05, 2019, 04:39:41 PM
#2
Thanks for the info.

Groupings were, indeed, the problem.  All the lost lines were in groups.

All drawings were 2D that, after a couple of more steps, are inputs to a laser cutter.  I liked thing in groups so I could easily move them around to optimize time and material on the laser.  The no groups requirement is inconvenient but not a show stopper.

Another issue I have not clearly defined is loss of dimensional stability, which is important to a laser cutter feed.  Some .svg files hold their size perfectly while others become larger.  I have not had enough time to determine what sequence of events drives a particular outcome.  Solving this has to be done at the shop and it will be days before I can get there to sort the dimensional problem out one way or the other.

Logged